License Agreement

PCMedik is not free software. The software is the copyright of PGWARE and is protected under international law. You may not sell, rent or lease this software. Reverse engineering, decompiling or disassembling the software, and use of the software to create competitive products, is expressly forbidden.

This is a legal agreement between you and PGWARE. Subject to your acceptance of the conditions and restrictions set out below, you are granted a free-of-charge license giving limited rights to use the software.

  • This software is provided as is. All responsibility for determining fitness of purpose rests with you, the user, for which purpose the free evaluation period is provided. On purchase of a full license, you are deemed to have agreed that the software is fit for the intended purpose of use. No refund of the license fee shall be entertained thereafter, for whatever reason.

  • You agree not to hold PGWARE liable for any loss or damage or consequential loss or damage arising directly or indirectly out of the use of the software or for any other reason. You accept that it is entirely your responsibility to take all necessary precautions to safeguard against any such loss, damage or consequential loss or damage, howsoever it may be caused.

  • You agree to use the software solely and exclusively for the purposes of evaluation, for a period of not exceeding 28 days. On the expiry of this period, or when you have completed your evaluation (whichever comes first) you agree to either a) obtain a full license for the software, or b) cease using the software and to delete all the installed copies of the software that you have made.

  • You agree to the software connecting to the internet periodically to verify that the Name/Serial entered into the software and only this information is valid and any action taken on our part if the serial number is proven to be invalid.

    • Obtaining an Unrestricted Software License

    One full license must be purchased for each non-networked system on which the software is installed and used. In the case of systems in which the program is simultaneously accessible to more than one user at a time, such as a network server, one full license must be purchased for each user who is capable of accessing the software. Distributing the serial number or using it on more then one machine will without prior notice lead to it being banned in further versions of the software.

    Registering the Software
    How to Register
    Enter Serial Number


Registering the Software

PCMedik is not free software. You are required to pay a registration fee and register the software if you wish to continue using it after an evaluation period of not exceeding 28 days.

The software itself is not time limited in days. However the software is disabled in the shareware package.

When you register the software you will receive a serial number which you must enter in the program's registration screen. After this serial number is entered you will be able to select the 'Heal & Boost' setting. The 'Heal & Boost' setting will then fix and optimize computer performance for optimal performance.

License Agreement
How to Register
Enter Serial Number


How to Register

One full license must be purchased for each non-networked system on which the software is installed and used. In the case of systems in which the program is simultaneously accessible to more than one user at a time, such as a network server, one full license must be purchased for each user who is capable of accessing the software. Distributing the serial number or using it on more then one machine will without prior notice lead to it being banned in future versions of the software.

This program can be registered through our agents setSystems. setSystems can be located on the World Wide Web at the following URL:

http://www.setsystems.com/

Registration costs $9.31 US dollars.

You can register online using your credit card. setSystems offers secure transactions for users of Netscape or Microsoft Internet Explorer. To go to the registration page for PCMedik go to:

http://secure.pgware.com/purchase.php?product=pcmedik

Alternatively, you can send a check or money order (in US Dollars drawn on a US bank), made payable to setSystems to:

setSystems
1257 Lake Plaza Drive
Suite 230
Colorado Springs, CO 80906
U.S.A.

On the check or money order include your e-mail address and the Product - PCMEDIK, or include a small note with the check/money order with this information.

Also you can call the toll-free number 1-888-201-7131 to purchase. Callers from outside the US should call 1-719-576-0115.

Finally you can fax in the order. Include your full name, address, phone number, credit card details and your email address. Make sure to reference Product - PCMEDIK. Faxes should be sent to: +1 (719) 623-0399.

Upon registration (allow up to 1 working day for your registration to be processed) you will receive your serial number. This will be sent by e-mail if an e-mail address was specified when registering. When you receive your serial number, enter the Name/Serial in the program's registration screen and hit OK. The software will then behave as a fully licensed version.

License Agreement
Registering the Software
Enter Serial Number


Overview

PCMedik is a tool that optimizes your computer performance. Tired of your computer crashing or acting real slow? PCMedik is medicine for your computer and heals these problems from occuring. PCMedik also boosts your computer performance by modifying several system settings, so you can now use that old computer of yours at optimum performance. No installation or modification needs to be made to your hardware, PCMedik does all the complicated settings for you instantly.

PCMedik works by fixing several registry settings on your computer as well as several configuration files. However those are not the only changes made to your computer. PCMedik also allocates roughly 20% of your computer's RAM/Memory to the processor, this increases Windows® stability and increases your computer's performance. PCMedik solves Windows® crashes by capturing errors that occur and then quietly closes the application causing the problems. Increase your productivity on your computer today without worrying about system crashes and slow performance with PCMedik.

PCMedik is quite easy to use and understand. With a few button pushes and setting changes the application is ready to work. After the settings have been made, you will need to reboot your computer and it will be ready to use at optimal performance. Try PCMedik for 28 days and if you find it useful please do register.

System Requirements

  • Microsoft Windows 95, 98, 2000, Me, XP, NT 4.0
  • Microsoft Internet Explorer 3 or higher
  • Intel Pentium 90 MHz or higherLI>
  • 8 Mb RAM (32 Mb recommended)
  • 5 Mb hard disk space
  • VGA or higher resolution monitor
  • Mouse or other pointing device

    • Note Internet Explorer is not required to be the default browser.

    How It Works
    Registering the Software


How It Works

PCMedik works by modifying multiple Windows registry entries as well as system files to increase computer performance. The process begins by PCMedik locating all installed hardware and software on your computer and then runs through pre-defined routines to diagnose and find flaws or problems. Then PCMedik based on your computers' configuration determines appropriate values to modify accordingly. The whole process should take under two minutes to complete.

PCMedik Modifications

  • Maximum and minimum file cache
  • Memory swap file/conservative swap file
  • Windows animation settings
  • Legacy Windows support
  • File allocation size and buffers
  • Windows system resources
  • Boot optimization
  • Application priority level
  • Device drivers
  • Software incompatibilities
  • and much more...

    • Overview
    Registering the Software


Main Window

Operating System

The control [image] determines the operating system the computer uses. PCMedik will try to automatically determine the operating system the computer is using. It is important that the correct operating system is choosen as this affects the changes and settings made to your computer.

Processor Type

The control [image] determines the central processing unit/processor the computer uses. PCMedik will not try to automatically determine the central processor the computer is using due to the numerous different types available on the market. You can determine what type of processor your computer uses by checking the computer's help booklet/manual. If you do not know the processor type choose 'Unknown/Other Processor' and PCMedik will use generic settings. It is preferable to choose either the Intel or AMD processor type if your computer uses one of these, as more specific setting changes are made to your computer.

Repair Setting

The control [image] determines the setting to modify your computer to use. The best option is to use the 'Heal & Boost' setting, however this is not available until you register the software. Please test using the 'Heal' setting before deciding to register. Also note that the 'Heal & Boost' setting adjusts your computer performance greatly compared to the 'Heal' setting.

Restore/Go Buttons

The control [image] modifies your computer settings, based on the options you have choosen in PCMedik.

The control [image] restores your computer settings back to it's original condition before using PCMedik.

Enter Serial Number


Registration Window

Enter Name/Serial

This window allows you to enter the serial number which was e-mailed to you after purchasing the software. Please make sure to enter the Name/Serial EXACTLY as printed in the e-mail.

Please click the link Click to order PCMedik - $9.31 (USD) to purchase the software and receive your serial number. Before deciding to purchase, review the PCMedik License Agreement.

License Agreement
Main Window


Frequently Asked Questions

  • Do I need to run PCMedik everytime I restart my computer?

      • Yes and no, PCMedik needs to only be run once. After you register the software and choose the 'Heal & Boost' option you will never again 'have' to run the software. However you should run PCMedik again only after you install new hardware or software to your computer. This will insure that any problems that may have resulted from the installation are detected before your computer system becomes unstable.

  • If I register will the 'Heal & Boost' setting do anything more?

      • Yes, the 'Heal & Boost' setting uses the most optimal settings for your computer. When PCMedik was developed the 'Heal' setting was degraded down to use average boost settings, the 'Heal & Boost' setting on the other hand will use all performance settings available for your computer.

  • I have noticed that when I start PCMedik it attempts to access my internet connection, why is this?

      • Unfortunately there are many users of our software previously which have chosen to pirate our software rather then pay the very small license fee. For this reason PCMedik will attempt to verify the Name/Serial each time the software is started. No other personal information other then the Name/Serial is transmitted over the internet.

  • I want to purchase PCMedik but I do not feel comfortable buying online, is there any other option?

      • Yes, you can also purchase the software by PHONE, FAX or MAIL if you do not feel comfortable purchasing ONLINE. Please note however that we will only send you the serial number after we receive payment. Typically customers who purchase by ONLINE or PHONE or FAX will receive their serial number within 48 hours, purchases by MAIL can take up to 2 weeks. For more information please read over the How to Register topic.

    Technical Support


Technical Support

To obtain support for PCMedik please contact us with the problems you are having and/or bugs you have found. You are encouraged to e-mail us with enhancments you would like to see in PCMedik however we probably will not be able to reply to everyone with a definitive answer. Registered customers have priority over non-registered customers in all cases. Most support questions will be handled within 24-48 hours. If you would like to inquire about site licensing or large license purchases please contact us.

To Obtain Support Use The Following Methods:

WWW: http://www.pgware.com/support.html
E-mail: support@pgware.com
Fax: 815-425-8539 (US)

To Report Software Piracy:

WWW: http://www.bsa.org/usa/report/
E-mail: piracy@pgware.com

Questions, comments and technical support are provided between Mondays - Friday from 8 am - 5 pm. Please note however we are closed on major holidays so replies to your requests may be significantly delayed.

Frequently Asked Questions